#1  
Alt 08.01.2018, 22:58
Thomas3025 Thomas3025 ist offline
Neuer Benutzer
 
Registriert seit: 08.01.2018
Beiträge: 2
Standard Gramps - Probleme mit Datenbank-Versionen

Hallo zusammen,

zunächst noch allen, die mitlesen, ein gutes neues Jahr.

Vor einiger Zeit habe ich recht intensiv vorhandenes Wissen über die eigenen Vorfahren gesammelt und mit Gramps verwaltet. Irgendwann hat dann leider sie Zeit nicht mehr gereicht, sich weiter intensiv mit dem Thema zu beschäftigen. Letzte Woche wollte ich mir mal wieder den alten Stand anschauen, was misglückte, weil die Datenbank offenbar zu alt für den aktuellen Programmstand ist. Folgende Fehlermeldung wird beim Versuch, die Datenbank zu öffnen, ausgegeben:
Zitat:
Willst Du wirklich den Stammbaum aktiualisieren?
Der Stammbaum, den Du versuchst zu laden, befindet sich im BSDDB Version (5, 1, 29) Format. Diese Gramps Version verwendet BSDDB Version (5, 3, 28). Daher kannst Du diesen Stammbaum nicht laden, ohne die BSDDB Version des Stammbaums zu aktualisieren....
Wenn ich nun die Option wähle, den Stammbaum zu aktualisieren, wird die Datenbank zerstört und lässt sich gar nicht mehr öffnen.

Die aktuell installierte Gramps-Version ist 4.1.1-1 auf einem Linux-System.

Ich habe Gramps Version 2.2.10 installiert, dort ist der Fehler der Gleiche.
Der Versuch, Version 2.2.2 zu installieren schlug fehl, weil unerfüllte Paketabhängigkeiten vorlagen, die ich nicht aufgelöst bekommen habe.

Mein nächster Versuch wäre jetzt, eine ältere Version von Debian oder Ubuntu zu installieren, auf der ich die Version von Gramps zum Laufen bekomme, mit der ich meine alte Datenbank öffnen und sichern/exportieren kann.

Nun die eigentliche Frage:
Weiß jemand, mit welcher Version von Gramps ich die Datenbank im BSDDB Version (5, 1, 29) Format öffnen kann und unter welcher Debian- bzw. Ubuntu-Version diese Gramps-Version läuft.

Ich bin für jeden Hinweis dankbar. Es wäre sehr ärgerlich, wenn die ganze Zeit, die ich in die Erfassung gesteckt habe, völlig umsonst gewesen wäre.

Viele Grüße

Thomas
Mit Zitat antworten
  #2  
Alt 14.01.2018, 23:25
Benutzerbild von DaMaFe
DaMaFe DaMaFe ist offline
Erfahrener Benutzer
 
Registriert seit: 20.10.2012
Beiträge: 184
Standard

Ich benutze auch Gramps auf Linux. Ich hatte vor längerer Zeit auch mal Probleme mit der Datenbank nach Upgrade, daher weiss ich, dass die Fehlermeldung ärgerlich ist.
Hast Du schon mal auf der Gramps-Hilfeseite geschaut? Hier gibt es folgende Beiträge, die zur Lösungsfindung führen könnten:
Wenn dies nicht hilft, dann direkt bei den Gramps Entwicklern ein Bug Ticket öffnen. Dies kannst Du hier einreichen:

https://gramps-project.org/bugs/my_view_page.php
__________________
Wer in der Zukunft leben will
Muss in der Vergangenheit blättern.
Mit Zitat antworten
  #3  
Alt 16.01.2018, 22:28
Thomas3025 Thomas3025 ist offline
Neuer Benutzer
Themenstarter
 
Registriert seit: 08.01.2018
Beiträge: 2
Standard

Hallo,

vielen Dank für den Hinweis. Ich hatte wohl die Google-Suche bemüht, aber die genannten Hilfeseiten so nicht entdeckt. Der zweite Link war sehr hilfreich. Mit den Infos konnte ich zumindest schonmal die richtige DB-Version installieren. Leider bekomme ich es jetzt noch nicht hin, dass Gramps auch genau diese Version nutzt. Das habe ich jetzt mal in den Bug Tracker eingestellt.

Viele Grüße

Thomas
Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
gramps datenbank bsddb

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu

Alle Zeitangaben in WEZ +2. Es ist jetzt 17:44 Uhr.