Zurück   Ahnenforschung.Net Forum > Software und Technik > Genealogie-Programme
Hier klicken, falls Sie Ihr Kennwort vergessen haben.

Hinweise

Antwort
 
Themen-Optionen Thema durchsuchen Ansicht
  #1  
Alt 14.04.2021, 14:03
Saturn1955 Saturn1955 ist offline männlich
Benutzer
 
Registriert seit: 11.12.2020
Ort: Berlin
Beiträge: 18
Standard lifelinechartview plugin nicht instalierbar ( lubuntu 20.04 )

hallo,


ich möchte gerne das lifelinechartview plugininstalieren, dies klappt aber nicht, da svgwrite fehlt, was auch nicht nachinstalierbar ist. Kann mir jemand hier Hilfestellung leisten?
Mit Zitat antworten
  #2  
Alt 14.04.2021, 14:22
sonki sonki ist offline
Erfahrener Benutzer
 
Registriert seit: 10.05.2018
Beiträge: 3.861
Standard

Für svgwrite brauchst du:
1. Python 3.6+
2. pip install svgwrite
Mit Zitat antworten
  #3  
Alt 14.04.2021, 14:49
Saturn1955 Saturn1955 ist offline männlich
Benutzer
Themenstarter
 
Registriert seit: 11.12.2020
Ort: Berlin
Beiträge: 18
Standard

Code:
 Der Befehl 'pip' wurde nicht gefunden, aber es gibt zu 18 ähnliche Befehle.


saturn@aspire8930:~$ sudo apt-get install python3.6
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Hinweis: »python3.6-2to3« wird für regulären Ausdruck »python3.6« gewählt.
Hinweis: »libpython3.6-stdlib« wird für regulären Ausdruck »python3.6« gewählt.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.

klappt irgendwie nicht so

Geändert von Saturn1955 (14.04.2021 um 14:54 Uhr)
Mit Zitat antworten
  #4  
Alt 14.04.2021, 15:43
sonki sonki ist offline
Erfahrener Benutzer
 
Registriert seit: 10.05.2018
Beiträge: 3.861
Standard

Moment, du hast python installiert, aber pip ist nicht verfügbar? Das kann ich mir fast nicht vorstellen.
Mit Zitat antworten
  #5  
Alt 14.04.2021, 16:44
AllaDann AllaDann ist offline
Benutzer
 
Registriert seit: 12.01.2017
Beiträge: 93
Standard

Bei mir auf dem Mac funktionierte pip auch nicht, sondern nur pip3
Mit Zitat antworten
  #6  
Alt 14.04.2021, 18:37
Benutzerbild von Andre_J
Andre_J Andre_J ist offline
Erfahrener Benutzer
 
Registriert seit: 20.06.2019
Beiträge: 1.208
Standard

Zitat:
Zitat von Saturn1955 Beitrag anzeigen
saturn@aspire8930:~$ sudo apt-get install python3.6
Das Paket heißt python3. Sollte aber bei dir schon geladen sein, denn ohne läuft gramps eh nicht.

Dann gibt es noch ein Paket python3-svgwrite, das könnte die Abhängigkeit auflösen. Und
sudo apt-get update python3-pip
installiert dir pip. Aufrufen muß man es mit
pip3 install svgwrite
Das meldet aber nur, dass svgwrite schon in der aktuellen Version von Ubuntu bezogen wurde.


Gruß,
Andre_J

Geändert von Andre_J (14.04.2021 um 18:51 Uhr)
Mit Zitat antworten
  #7  
Alt 14.04.2021, 20:00
Saturn1955 Saturn1955 ist offline männlich
Benutzer
Themenstarter
 
Registriert seit: 11.12.2020
Ort: Berlin
Beiträge: 18
Standard

ich bekomme als Anwort bei der versuchten Installation, dass svgwrite nicht geöffnet werden kann, obwohl es installiert ist, was mit Deiner Hilfe auch ging. Aber ich komme da leider trotzdem nicht weiter
Mit Zitat antworten
  #8  
Alt 14.04.2021, 20:29
Benutzerbild von Andre_J
Andre_J Andre_J ist offline
Erfahrener Benutzer
 
Registriert seit: 20.06.2019
Beiträge: 1.208
Standard

Dann kopier doch mal die Fehlermeldung hier rein. Bei mir hat es geklappt, mit Linux Mint 20.1 .
Mit Zitat antworten
  #9  
Alt 14.04.2021, 21:57
Saturn1955 Saturn1955 ist offline männlich
Benutzer
Themenstarter
 
Registriert seit: 11.12.2020
Ort: Berlin
Beiträge: 18
Standard

[CODE][
Installationsfehler Die folgenden Erweiterungen hatten Fehler ( Netzwerkgrafik 0.0.23

/CODE]


dann


Lifel line chartview plug in

das benötigte Modul svgwrite in version 1.4. konnte nicht geladen werden


das sind die Fehlermeldungen

Geändert von Saturn1955 (14.04.2021 um 22:01 Uhr)
Mit Zitat antworten
  #10  
Alt 15.04.2021, 09:11
Benutzerbild von Andre_J
Andre_J Andre_J ist offline
Erfahrener Benutzer
 
Registriert seit: 20.06.2019
Beiträge: 1.208
Standard

Zitat:
Zitat von Saturn1955 Beitrag anzeigen
das benötigte Modul svgwrite in version 1.4. konnte nicht geladen werden
Stimmt. Merkwürdigerweise ist python3-svgwrite noch version 1.3.1, und pip will es nicht updaten. Also hilft nur der Holzhammer:

sudo apt remove python3-svgwrite
pip3 install svgwrite

und damit sollte Version 1.4.1 installiert sein.
Dein Fehler bezieht sich aber auf das plugin Netzwerkgrafik, und nicht lifelines. Netzwerkgrafik und Graphenansicht lassen sich bei mir auch nicht installieren.

Um die Abhängigkeiten zu prüfen, kann man im obersten Tab "Gramplet Werkzeugbank" das Addon "Vorraussetzungen Prüfer" einrichten. Der erzählt mir für das addon Netzwerkgrafik:
(networkx nicht installiert)(Graphviz 2.43)
und eines von beiden: (pydotplus: nicht installiert) oder (pygraphviz: nicht installiert)

und für das addon:Graph View:
(GooCanvas:nicht installiert)(PyGoocanvas: TBD?)(Graphviz 2.43)

Also:

sudo apt-get install python3-networkx python3-pygraphviz libgoocanvas-2.0-dev

und danach klappts auch mit den beiden addons.

Geändert von Andre_J (15.04.2021 um 09:49 Uhr)
Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu

Alle Zeitangaben in WEZ +2. Es ist jetzt 18:31 Uhr.